おそらくAndroidの場合はGoogle側の強制がないからOSリリース対応ポリシーはこちらで決めないとダメなんだろうな〜と。

例えばもうリリースから2年過ぎているのでOS1.6~2.1は対応はやめる。
OS2.2は2012年末で対応終了
2013年初よりOS2.3以上対応など
アプリをリリースする際に記載しておくのが必要かもしれないですね。

アプリのテストしてたんだけど動作速度と解像度が足を引っ張るのでもっといいものを!と思っても機能を削るしかなくなってしまうのでこれはダメだなと。
日本国内でメーカーを問わず該当するOSが初めて発売されてから2年ならいいよね。